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Customer Payments Portal Setup and Processes

Document #: 3450 Product: CenterPoint® Accounting

The Customer Payments Portal allows you to accept credit card or e-check (ACH) payments online from your customers. Red
Wing Software joined forces with Clover Connect, a premier integrated payments solution provider, to offer seamless payment
processing within CenterPoint Accounting. The Customer Payments Portal works with the invoice emailing feature in
CenterPoint. When customers receive their invoice or statement, the email will contain a link to a unique Invoices Due web page
where they can pay outstanding invoices online. Those payments are then imported into CenterPoint as receipts applied to the
invoices.

Step 1: Set Up the Customer Payments Portal

Add and Register the Customer Payments Portal

Set Up Emailing of Invoices

Step 2: Enter Customer Invoices and Send Via Email

Step 3: Get Customer Receipts from the Customer Payments Portal

Manage the Customer Payments Portal in CenterPoint

Customer Open Invoices

View Imported Receipts in Transaction Search

Frequently Asked Questions

Step 1: Set Up the Customer Payments Portal

Prerequisite: To use the Customer Payments portal, you must have an account with Clover Connect for credit card or
e-check (ACH) processing. If you have not done so already, contact the RedWing Software Sales department to connect with
Clover Connect and activate the Customer Payments Portal.

Add the Customer Payments Portal

1. If CenterPoint is not open, start CenterPoint by double-clicking your CenterPoint icon on your desktop.
2. Select File > Administration >Module Configuration Manager.
3. SelectOnline Services, select Customer Payments Portal, and then clickOK twice.
4. Close CenterPoint, double-click the CenterPoint icon on your desktop to restart it, and then open your database.

Register the Customer Payments Portal

1. In CenterPoint, select Setup >Online Services.



2. Click Register.

3. After registration is complete, select the Customer Payments Portal tab.

4. In theMerchants Name box, enter the name that you want your customers to see in the Customer Payments Portal.
5. Enter your Contact Email and Contact Phone that you want displayed in the Customer Payments Portal.
6. If you want your logo to display in the Customer Payments Portal, click the Upload button, select the logo file (the file

must be between 0 and 150 kb and can be any image file format, for example .jpg, .bmp, .png, etc.), and then clickOpen.
To preview the logo, click Preview and to remove the logo, click Remove.

7. Select the Bank Account and Discounts Account to use when importing customer payments from the Customer
Payments Portal into CenterPoint as receipts. Enter yourMerchant ID (MID), API Username, and API Password
credentials provided to you by Clover Connect for processing credit card payments. Click Validate to verify the
credentials are accurate.

8. ClickGenerate Test Transaction.This process generates a test invoice for $1.00, which can be paid through the
Customer Payments Portal to test the Clover Connect merchant configuration. The test transaction will not update
CenterPoint Accounting.

9. ClickOK to pay the test transaction through the Customer Payments Portal.
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10. Click Pay, select the method of payment: Credit Card Information or E-Check Information (this payment option is
available only if the Merchant ID is configured with Clover Connect to accept e-check (ACH) payments), enter your credit
card or bank account information, and then click Submit.

11. If the test payment is approved, a receipt will display for your records.

12. Switch to the CardPointe portal to verify the $1.00 payment and void the transaction to void/refund the $1.00. If you have
questions on CardPointe functions, contact Clover Connect.

13. You can generate a test transaction as often as necessary.

RedWing Software • support@redwingsoftware.com • www.redwingsoftware.com • 800-732-9464 Page 3 of 10

This documentation is for informational purposes only. For specific accounting guidance, please contact your accountant. Last Updated 10/12/2023



Set Up Emailing of Invoices
Only customers who are configured to receive invoices via email will be included in the Customer Payments Portal. If you email
statements, customers who receive emailed invoices will also have a link to pay online included with their billing statement
email. For full instructions on how to email customer invoices, please see the Emailing Customer Invoices topic. If you are
already sending customers invoices via email, continue to Step 2.

1. Setup Email Preferences
a. Select File > Preferences.
b. On the left, select Email Setup > Email Setup, and then select the Database tab at the top .
c. Enter the required information.
d. On the left, select Customer Invoices.
e. Enter a default Subject andMessage and select the Form for emailing invoices.
f. Optional: Select Billing Statements to enter defaults for emailed statements.
g. Click Save.

2. Set Up Customers to Receive Invoices by Email
a. Select Setup > Names or Setup > Customers
b. Edit the appropriate customer.
c. Click the Email/Print tab.
d. Enter the Name and Email Address(es) that will receive invoices emailed to this customer.
e. Select Send “To”, Send “CC”, or Send “BCC” for Invoices for each email address.
f. Optional: Set the email options for Statements if you would also like this customer to receive emailed billing

statements. If they receive emailed invoices, the statements will also contain the link to pay online.
g. Click Save.
h. Repeat for each customer who will receive emailed invoices.

3. Set Up Sent from Email

Note: If this step is not completed, the email address used for Test Settings in the Email preference will be used as the
From email address.

a. Select Setup >General Email Addresses.
b. Enter the Name and Email Address and select how Customer Invoices and Print Checks/Invoices

should be sent.
c. Click Save.

Step 2: Enter Customer Invoices and Send Via Email
When you enter an invoice for a customer set to email invoices, the Email button at the bottom of the invoice screen will show a
green check mark to indicate that when the invoice is saved, the customer will receive the invoice via email.

The customer will receive an email that contains a link to pay their invoices online.
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Step 3: Get Customer Receipts from the Customer Payments Portal
Credit card payments your customers make online can be brought directly into CenterPoint as receipts applied to their invoices.

1. Select Processes > Customer Payments Portal >Get Customer Receipts.

2. In the Next Receipt Number box, the next sequence number for receipts will display or enter the next Receipt Number to
use when generating receipts.

3. The available online payments for the registered database will display. Click Import to generate receipts for all available
online payments.

4. At the This will generate receipts for all available online payments, continue? message, click Yes.
5. When the process completes successfully, the following screen displays.

6. ClickOK.

Manage the Customer Payments Portal in CenterPoint

Customer Open Invoices
The Customer Open Invoices option allows you to review the status of open customer invoices on the Customer
Payments Portal and post any invoices that are not currently online. It also has an option to launch the Customer
Payments Portal for a specific customer.
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1. Select Processes > Customer Payments Portal > Customer Open Invoices.

2. If you want to filter the list, select the Customer to filter by.
3. Invoices from the Customer Payments Portal will display in invoice date descending order. The Status of

the invoices can be one of the following:
Offline: The invoice is not on the Customer Payments Portal.
Not Synched: The invoice is on the Customer Payments Portal, but the Amount Due doesn't match
with CenterPoint.
Online: The invoice is on the Customer Payments Portal with no Amount Paid or Discount Applied
and the Amount Due is the full amount remaining.
Payment: The invoice is on the Customer Payments Portal with a partial payment applied.
Paid: The invoice is paid in full on the Customer Payments Portal. The invoice has not been
imported into CenterPoint.

4. If an invoice has a status of Offline or Not Synched, select the Upload check box and then click the Upload
button to upload the invoice to the Customer Payments Portal (invoices can only be uploaded if the
customer is configured to receive emails for customer invoices).

5. Right-click and select Refresh to update the screen with changes made on the Customer Payments Portal.
6. To view the online Customer Payments Portal for a specific customer, right-click on an invoice for the

customer and select View Customer Invoices Online for "Customer Name".

View Receipts from the Customer Payments Portal in Transaction Search
The receipts will come into CenterPoint as “Receipt” transactions, just as if they were entered into CenterPoint
directly. They are visible in Transaction Search and on any reports where you would normally review receipts. In
addition, receipts from the Customer Payments Portal have a Payment Type of Customer Payments Portal, and
Memo Line 1 will contain a CPP label followed by the Confirmation Code/Reference Id of the online payment.
To easily find all Customer Payment Portal Receipts:

1. Select Reporting Tools > Transaction Search.
2. On the left side of the screen, clickMore Items and select Payment Type.
3. In the Payment Type box, select Customer Payments Portal.
4. Enter any other search selections, such as Customer or Date.
5. Click Search.
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Frequently Asked Questions
Q: Can I see what my customers will see when they go to the Customer Payments Portal?
A: Yes, on the Customer Open Invoices screen, you can right-click on any invoice and choose View Customer
Invoices Online for "Customer Name" to launch that customer's Customer Payments Portal. This is an
example:

Customers can choose to pay the full amount due, or if they have multiple invoices, click the View Details to see
the individual invoices. They can unselect any invoices they do not wish to pay at this time and click Pay to pay the
selected invoices.
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They can choose to pay the amount due or make a partial payment. They will enter their credit card or bank
account information (this payment option is available only if the Merchant ID is configured with Clover Connect to
accept e-check (ACH) payments), and click Submit to make the payment. If their credit card or e-check
information is approved, a receipt will display that they can print for their records.

Q:My company applies a surcharge to customers paying with a credit card. How are customers informed of the
surcharge?
A: If your Merchant ID is set up by Clover Connect to apply surcharges, a message will display the surcharge
percentage in the Customer Payments Portal and the amount of the surcharge applied will display on the payment
screen and receipt.
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Q:My customer deleted the email. How do I get them a new link to the Customer Payments Portal?
A: You can email them a new copy of the invoice from Processes > Sales > Print/Email Invoices.
Q:What happens if I edit or delete an invoice that is already uploaded to the Customer Payments Portal?
A: CenterPoint will sync with the Customer Payments Portal and remove the deleted invoice or update the invoice
with the edited information.
Q:My customer does not want to pay online, what happens to the invoice on the Customer Payments Portal?
A: Your customer can continue to pay the way they have in the past. When the receipt is entered in CenterPoint to
pay the invoice, the invoice will no longer be available to pay on the Customer Payments Portal.
Q:My customer called to pay with a credit card. Can I process the credit card on the Customer Payment Portal so
that the payment can be imported into CenterPoint?
A: Yes, from Processes > Customer Payments Portal >Open Customer Invoices, right-click on the invoice
and select View Customer Invoices Online for “Customer Name”. This will bring you to their Customer
Payment Portal page where you can select the invoice(s) and make a payment using the credit card information
they provide.
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Q: A customer made a payment and the invoice was not found in CenterPoint. How is this reconciled?
A: In the rare occurrence that a payment made on the Customer Payments Portal cannot be matched with an
open invoice in CenterPoint (for instance, the payment was made online, and then a receipt was entered in
CenterPoint before the online payment was imported) CenterPoint will prompt you that it needs to create a
customer deposit for this payment.
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